Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - wisnusanjaya

Pages: [1]
1
dah lama ga nge post


666 or 777 are not dangerous, but 644 or 664 are the recommended permissions for everyday use.


4 (read only), 5 (baca dan eksekusi), 6 (membaca dan menulis) dan 7 (membaca, menulis dan mengeksekusi)


kalau untuk user dan grup /var/www/htm/

user dan groupnya apache kalau turunan redhat kalau turunan debian www-data

 :) :)

2
Tutorial, Artikel, Tips dan Trik / Tentang CLAM Anti Virus di ClearOS
« on: Saturday, 09 February 2013, 22:13:40 »
baca-baca di sini http://www.clamav.net/lang/en/

lihat Versi clamav
# clamscan -V

Update clamav
# freshclam

Versi update clamav
# fressclam –v


Directory clamav
/var/lib/clamav

tempat config
/etc/freshclam.conf

service clamav
# service clamd restart atau stop atau start

Disable auto update clamav
# nano /etc/freshclam.conf

ganti
# Check for new database 24 times a day
Checks 24

ubah menjadi

Checks 0


untuk update manual
# freshclam

3
Tutorial, Artikel, Tips dan Trik / TUT EXTUNDELETE di clearos 6.3
« on: Friday, 18 January 2013, 22:33:42 »
lagi ngeremote server ga sengaja ke delete file-file di diretory server  :'(  tenang  masih bisa di kembalikan kok  O:-)


pakai undo di winscp atau ctrl-z  :D ternyata ga bisa  :D

atau kedelete lewat ftp, dari flexshare, atau kedelete webservernya, tinggal exundelete aja directorynnya  :)

ga sengaja ke delete


Install aplikasi untuk undeletenya
Code: [Select]
# yum --enablerepo=clearos-contribs install extundeleteCek dev hardisk
Code: [Select]
# fdisk –l

cara gunaiin exundelete
Code: [Select]
# extundelete /dev/mapper/vg_system-lv_root --restore-directory /etc/rc.d/init.d
Pastikan pathnya bukan symbolic linknya, contoh di atas symbolic link nya /etc/init.d itu ga bisa aslinya ada di /etc/rc.d/init.d



Directory recovery ada di /root bukan /<root>




Copy dulu recovery nya ke directory sebelahnya sementara, terus copy lagi ke tempatnya, umummnya hak akses permissionnya 755, silahkan ubah nilainya jadi 755

Opsi lain extundelete

Code: [Select]
# extundelete --help
di winscp ada tempatsampah kata om sawabi
untuk winscp versi 5 cara aktifkan tempat sampah


4
Tutorial, Artikel, Tips dan Trik / change hostname DDNS clearos
« on: Tuesday, 15 January 2013, 00:22:56 »
kadang hostname DDNS yang kita dapatkan ga sesuai dengan keinginan kita !!!

maksudnya biar gampang di ingat aja, setelah registrasi biasanya dapat otomatis, cuma kalau dapat tidak sesuai keinginan, kita bisa registrasi ulang caranya dengan mendelete system yang sudah kita register lalu daftar lagi dengan nama system baru.




login ke portal dengan user dan password anda

https://secure.clearcenter.com/portal/index.jsp








lalu register ulang deh, mudah-mudahan dapat hostname yang sesuai keinginan dan gampang di ingat




kalau ada cara lain kasih tau ya, selama ini saya gantinya pakai cara ini

5
Tutorial, Artikel, Tips dan Trik / kandangin paket yang sudah kita install
« on: Tuesday, 08 January 2013, 20:53:48 »
Saat kita install aplikasi atau paket, atau yum update, atau dari marketplace

menggunakan yum install namapaket, agar paket .rpmnya tersimpan di pc server barangkali sewaktu waktu perlu manginstall offline.

enablekan dulu keepchache di  /etc/yum.conf

keepcache=0 ubah jadi 1 untuk enable
coba lakukan instalasi paket apa saja, misal dari marketpace atau yum install namaplikasi,

maka paket akan tersimpan atau terjebak di /var/cache/yum

contoh om yono dah coba

"Update COS 52 manual telah berhasil dilakukan"
kumpulkan semua rpm yg terjebak, upload/copy ke COS
misal kita buat folder namanya update copy folder update ke COS
# cd update
#yum localinstall --nogpgcheck *.rpm
(waktu install jalur internetnya kumatikan biar pasti)
sudah termasuk upgrade php ke 52.17
setelah selesai coba memastikan kembali update langsung
#yum update
Install 0 Package(s)
Update 4 Package(s)
Remove 0 Package(s)

Total download size: 10 M
Is this ok [y/N]:


paket rpm ini sangat berguna jika kita mau update aplikasi offline di server selanjutnya atau install aplikasi offline

6
Tutorial, Artikel, Tips dan Trik / REPO-REPO di ClearOS 6.3
« on: Tuesday, 08 January 2013, 20:47:30 »
Repository adalah kumpulan paket software ataupun kumpulan aplikasi yang di kumpulkan di satu tempat media dalam hal ini bisa media CD,DVD,HD,LAN ataupun internet.

repo ini senjata buat para opreker

sebaiknya di usahakan pakai repo bawaan terlebih dahulu, jika tidak ada baru repo di bawah ini

Tambah repo yang ada di internet

install dulu aplikasi wget
# yum install wget

timb
# rpm -ivh http://download.clearfoundation.com/community/timb80/repo/clearos/6.3/os/i386/timb-release-1-1.noarch.rpm

epel
# wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
# rpm -ivh epel-release-6-8.noarch.rpm

rpmfusion
#  rpm -ivh http://epel.repo.unpas.ac.id/6/i386/epel-release-6-8.noarch.rpm
# yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/el/updates/6/i386/rpmfusion-free-release-6-1.noarch.rpm http://download1.rpmfusion.org/nonfree/el/updates/6/i386/rpmfusion-nonfree-release-6-1.noarch.rpm

remi
# wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
# rpm -ivh epel-release-6-8.noarch.rpm
# rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm

rpmforge
# rpm -ivh http://apt.sw.be/redhat/el6/en/i386/rpmforge/RPMS/rpmforge-release-0.5.2-2.el6.rf.i686.rpm

atrpms
# rpm –ivh http://dl.atrpms.net/el6-i386/atrpms/stable/atrpms-repo-6-5.el6.i686.rpm

centalt
# rpm -ivh http://centos.alt.ru/pub/repository/centos/6/i386/centalt-release-6-1.noarch.


# yum --enablerepo=* repolist

Tempat edit repo untuk enable dan disable dan melihat alamat url repo ClearOS
/etc/yum.repos.d
Untuk nilai
 1 = true
 0 =false
Ubahnya di
enabled=1

enable dan disable dari webconfig




untuk keamanan repo selain bawaan sebaiknya repo nya anda disable, dan jika mau di gunakan cukup ketikan :

contoh penampakan repo


# yum --enablerepo=timb-testing <perintah>
# yum--enablerepo=remi <perintah>
dsb lihat di /etc/yum.repos.d untuk nama

dan kalau mau intip paket apa aja lihat di urlnya di sana, buka di browser intip intip dulu reponya, ada tidak paket yang kita cari atau butuhkan

repo di internet bisa di gunakan jika ada koneksi internet


nanti saya update lagi kalau ada lagi





7
beberapa ISP tidak membuka port port umum seperti port ssh, port http, dll

kebetulan saya lg coba test ISP firstmedia teryata beberapa port di tutup

gmna cara ngakalinnya biar server bisa di remote?

atau bagi yang mau iseng mau ubah port buat kemanan biar port yang umum di ubah ke port yang tidak umum

ubah port ssh


ubah port webconfig dan webserver
kalau di mikrotik biasa pakai dstnat, tcp dstport in interface action

kalau di clearos kita pakai iptables
misal ip public kita ada di interface external nya ada di eth1

script iptablesnya
untuk webserver dan webconfig, port 9090 dan 9100 bisa anda ubah terserah anda

iptables -t nat -I PREROUTING -i eth1 -p tcp --dport 9090 -j REDIRECT --to-ports 80

iptables -t nat -I PREROUTING -i eth1 -p tcp --dport 9100 -j REDIRECT --to-ports 81

penampakan

cek interface eth external

add script iptables


karena ada 2 script add 2 script tersebut

jangan lupa buka port incomingnya biar bisa di aksess dari luar buka port yang tadi anda buat berarti 2222, 9100, 9090

penampakan



sekarang bisa akses remote deh

buka
http:namaserveranda.poweredbyclear.com:9090 untuk webserver
https:namaserveranda.poweredbyclear.com:9100 untuk webconfig
dan kalau mau buka ssh dengan winscp jangan lupa portnya jadi 2222 karena sudah di ubah

kalau aksess dari ip lokal pakai port 80 dan 81
atau mau bisa juga lokalnya portnya di ubah script ip table nya ganti jadi
iptables -t nat -I PREROUTING -p tcp --dport 9100 -j REDIRECT --to-ports 81
iptables -t nat -I PREROUTING -p tcp --dport 9090 -j REDIRECT --to-ports 80

8
masuk ke BIOS pilih power management setup pilih power on after power fail jadi On




9
Tutorial, Artikel, Tips dan Trik / TIPS mikrotik dengan standalone clearos
« on: Saturday, 21 July 2012, 00:41:50 »
auto on off proxy
==================
fungsinya saat clearos mati port 80 langsung tanpa proxy, jika clearos nyala port 80 menggunakan proxy


topologi di mikrotik
eth1= 192.168.7.1   (local/lan)
eth2= 192.168.1.2   (public atau dari modem bisa juga di isi ip public atau ppoe dynamic kalau otomatis)
eth3= 192.168.55.2 (to proxy)


topologi di clearos standalone
ipclearos= 192.168.55.1 dan gateway 192.168.55.2

1. redirect port 80 ke proxy dan kasih coment yang gunanya untuk auto on dan off
----------------------------
/ip firewall nat
add action=dst-nat chain=dstnat comment=RedirectToProxy disabled=no \
    dst-address=!ippublic dst-port=80 in-interface=LOCAL protocol=tcp \
    src-address=!192.168.55.0/24 to-addresses=192.168.55.1 to-ports=3128

2. buat script untuk mencari comment
------------------------------------
/system script
add name=ProxyDown policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/ip firewall nat set [find comment=RedirectToProxy] disabled=yes"
add name=ProxyUp policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/ip firewall nat set [find comment=RedirectToProxy] disabled=no"


3. buat netwatch untuk cek clearos nya hidup atau mati
------------------------
/tool netwatch
add disabled=no down-script=ProxyDown host=192.168.55.1 interval=5s timeout=\
    1s up-script=ProxyUp


forward port clearos agar bisa di aksess dari luar mengunakan port lain bukan port standart untuk keamanan

dst-address=ippublic (ippublic isi ip anda jika static) kalau ppoe arahkan interface ke ppoe nanti akses mengunakan dyndns clearos

akses webconfig clearos mengunakan port 1234 dari webluar
=====================================
/ip firewall nat
add action=dst-nat chain=dstnat comment=webconfig+ssh.server disabled=no \
    dst-address=ippublic dst-port=1234 protocol=tcp to-addresses=\
    192.168.55.1 to-ports=81

aksess ssh menggunakan port 2323
=========================
/ip firewall nat
add action=dst-nat chain=dstnat disabled=no dst-address=ippublic \
    dst-port=2323 protocol=tcp to-addresses=192.168.55.1 to-ports=22

webserver menggunakan standalone clearos ( ingat harus di kasih tanda ! di dst-address ipclearos agar bisa di aksess dari lan juga)
==========================================
/ip firewall nat
add action=dst-nat chain=dstnat comment=RedirectToProxy disabled=no \
    dst-address=!192.168.55.1 dst-port=80 in-interface=LOCAL protocol=tcp \
    src-address=!192.168.55.0/24 to-addresses=192.168.55.1 to-ports=3128
add action=dst-nat chain=dstnat comment=webserver disabled=no dst-address=\
    ippublic dst-port=80 protocol=tcp to-addresses=192.168.55.1 \
    to-ports=80

/ip service
set www disabled=no port=8088

/ip dns static
add address=192.168.55.1 disabled=no name=anu.poweredbyclear.com ttl=1d


torent
======================
/ip firewall nat
add address=192.168.55.1 disabled=no name=wisnusanjaya.com ttl=1d
add action=dst-nat chain=dstnat comment=torent disabled=no dst-address=\
    ippublic dst-port=9898 protocol=tcp to-addresses=192.168.55.1 \
    to-ports=9091

webmin
=================
/ip firewall nat
add action=dst-nat chain=dstnat comment=webmin disabled=no dst-address=\
    ippublic dst-port=1111 protocol=tcp to-addresses=192.168.55.1 \
    to-ports=10000


jika menggunakan standalone firewall buka incoming


10
==tut recovery data clearos sudah tidak bisa jalan lagi sudah di coba berbagai cara==

(khusus yang menggunakan LVM kalau tidak menggunakan LVMlangsung saja)
=============================

gunakan live cd linux
==TUT==
buka terminal
# su root
cek hardisk
# fdisk -l
terdeteksi hardisk saya ada di /dev/mapper/VolGroup00-LogVol00
# cd /tmp
# mkdir drive
# lvs
# vgchange VolGroup00 -ay VolGroup00
# mount /dev/mapper/VolGroup00-LogVol00 /tmp/drive

terus buka deh dengan file manager (dolphin)
dan arahin ke root /tmp/drive

silahkan copy paste ke hardisk lain
yang perlu di selamatkan biasanya :
---------------------------------
1. /var/flexshare/shares (data flexshare)
2. /var/www/html (isi website)
3. /var/www/virtual (isi website virtualhost)
4. /var/lib/mysql (database mysql)
5. /var/lib/transmission/Downloads (data torent)
6. /var/lib/BackupPC/pc (data backup pc)
7. /home (data FTP)
=========================================

==kernel panic==
edit grub


===tut error ext3===
tidak mau boot atau ada perintah fsck

jalankan live cd di server clearos

Gunakan Gparted untuk mencheck kondisi partisi hardisk, karena gparted menyediakan fungsi tersebut.
Lewat Partition, pilih hardisk system clearos yang rusak -> Check -> apply atau ceklist -> tunggu sampai selesai

reboot dan boot dari hardisk
=========selesai=========

Pages: [1]